Skip to main content

Posts

Showing posts from September, 2008

java code if and return

I have seen code that looks like this
public void static fn(boolean someCondition){ if(someCondition) { return error(); } return success(); }
Although there is nothing wrong in this, conventions suggest that this be written in a readable way like
return someCondition ? error() : success();
but lets say we have some more statements like this
public void static fn(boolean someCondition){ if(someCondition) { statement1; statement2; return error(); } statement2; statement4; return success(); }
I would consider it will be more readable to put it as
public void static fn(boolean someCondition){ if(someCondition) { statement1; statement2; return error(); }else{ statement2; statement4; return success(); } }

Bush administration's final straw: The new US dollor proposed!

One of the witty forwards I recieved in the recent past :)

Back to business

Hello all, I am back. I am glad to come back and to have my father recover well to the treament. He was diagnosed with Neuro Endocrine Carcinoma of Rectum (something related to colorectal cancer). I am planning on writing about his diagnosis and what he(and we) went through all this time. But good heavens, and wishes from a lot of friends and relatives - He is doing very well now.